Degraded model inference and dataset operations

Incident Report for Fastino Labs

Resolved

Issues resolved, prod redeployed.
Posted May 23, 2026 - 09:45 UTC

Update

We are continuing to work on a fix for this issue.
Posted May 22, 2026 - 18:11 UTC

Update

Impact has broadened: dataset uploads / downloads and billing usage history are also returning errors. Fine-tuned model inference that does not route through the affected provider remains operational. We are continuing work on a fix.
Posted May 22, 2026 - 15:30 UTC

Identified

We have identified an issue with an upstream cloud inference provider and are working to restore Claude-family request paths.
Posted May 22, 2026 - 11:38 UTC

Investigating

We are investigating reports of errors when calling Claude-family model inference. Some requests may fail or time out. Fine-tuned model endpoints are not affected.
Posted May 22, 2026 - 11:30 UTC
This incident affected: Pioneer (Brain API) and Identity & billing (Payments).