We're experiencing downtime right now. Our team is actively investigating.

Incident Report for Fastino Labs

Resolved

We are back!
Posted May 27, 2026 - 02:13 UTC

Update

We are continuing to work on a fix for this issue.
Posted May 27, 2026 - 02:13 UTC

Identified

Identified and fixing the issue.
Posted May 26, 2026 - 18:36 UTC

Update

We are continuing to investigate this issue.
Posted May 26, 2026 - 17:26 UTC

Investigating

We are currently investigating this issue.
Posted May 26, 2026 - 17:25 UTC